Back to overview
Downtime

Major Outage

May 19, 2026 at 10:33pm UTC
Affected services
Web App
API
Map Tiles

Resolved
May 20, 2026 at 1:40am UTC

Our upstream provider has restored service and the incident is now resolved.

Updated
May 19, 2026 at 10:45pm UTC

Our upstream cloud provider has identified the issue and is deploying a fix. Service should be restored shortly.

Created
May 19, 2026 at 10:33pm UTC

An upstream provider is experiencing a major outage, resulting in downtime for the Backtrack platform. We will provide updates as they're available.